HubNet Guide

NetLogo User Manual   

HubNet is a technology that lets you use NetLogo to run participatory simulations in the classroom. In a participatory simulation, a whole class takes part in enacting the behavior of a system as each student controls a part of the system by using an individual device, such as a TI-83+ calculator or a networked computer.

For example, in the Gridlock simulation, each student controls a traffic light in a simulated city. The class as a whole tries to make traffic flow efficiently through the city. As the simulation runs, data is collected which can afterwards be analyzed on a calculator or computer.

For more information on participatory simulations and their learning potential, please visit the Participatory Simulations Project web site.

About HubNet

HubNet Types

Currently, there are two types of HubNet available. One, called Calculator HubNet, was created in conjunction with Texas Instruments and makes use of the TI-Navigator system. This type of HubNet uses TI-83+ graphing calculators as the clients, the devices used to control a portion of a NetLogo model.

The second type of HubNet is Computer HubNet. This is adapted from the calculator version and uses laptop or desktop networked computers as the clients.

In the future, we hope to add more types of HubNet that support other types of clients such as PDA's (Personal Digital Assistants).

What do I need to get started?

Calculator HubNet

NOTE: TI-Navigator recently became commercially available. To learn more about the TI-Navigator system, visit Texas Instruments' site. However, HubNet does not work with this version of TI-Navigator; it might only work with a future release version of TI-Navigator.

Computer HubNet

First-time NetLogo user?

NetLogo is a programmable modeling environment. It comes with a large library of existing simulations, both participatory and traditional, that you can use and modify. Content areas include social science and economics, biology and medicine, physics and chemistry, and mathematics and computer science. You and your students can also use it to build your own simulations, if you choose.

In traditional NetLogo simulations, the simulation runs according to rules that the simulation author specifies. HubNet adds a new dimension to NetLogo by letting simulations run not just according to rules, but by direct human participation. Since HubNet builds upon NetLogo, we recommend that before trying HubNet for the first time, you should be familiar with the basics of NetLogo.

Teacher workshops

For information on upcoming workshops and NetLogo and HubNet use in the classroom, please contact us at

Getting Started With HubNet

Using NetLogo

We recommend that you become familiar with NetLogo itself before using the HubNet technology.

You can become familiar with NetLogo by trying out some of the models in the Models Library. Open the Models Library from the File menu in NetLogo. Then click on a model that you want to try and press the Open button. The Information tab in each of the models gives background information and instructions.

Other sections of the NetLogo User Manual may be helpful when learning NetLogo. We suggest that beginning users focus on the section Tutorial #1: Running Models.

If you have any questions about NetLogo, feel free to E-mail us. You can reach us at

HubNet Activities

Below are the current HubNet activities that are fully developed. Be aware that some of these models have only been implemented for one type of HubNet. For many models, you will find its educational goals and suggested ways to incorporate them into your classroom in the Participatory Simulations Guide which can be found on the Participatory Simulations Project web site.

NOTE: In addition to the discussion of learning goals and classroom techniques, these materials also contain step by step instructions and screen shots. As of December 2003, many are out of date and no longer match the actual activities in many respects. We are working on updating them. In the meantime, please use these materials for the discussions, but for step by step instructions, rely instead on the QuickStart Instructions built into the activities (see next section).

Running an activity

You'll find the HubNet activities in NetLogo's Models Library, under the HubNet Calculator Activities and HubNet Computer Activities folders.

In each of the activities, you'll see a box on the screen labeled "QuickStart Instructions". It contains step by step instructions on how to run that activity. Click the "Next>>>" button to advance to the next instruction.

We suggest doing a few practice runs of the activity before trying it in front of an actual class.

If you have any questions about running the activities, feel free to E-mail us. You can reach us at

Calculator HubNet

When you open the first Calculator HubNet activity for each session of NetLogo, you will be prompted by the TI-Navigator Login dialog. This prompts you to enter information (such as User Id or Password) that is necessary for connecting to the TI-Navigator system and running the HubNet activity. If you don't actually want to run the model, just press the Cancel button.

For more information about how to log in to the calculators and other details of using Calculator HubNet, please refer to the Participatory Simulations Guide which can be found on the Participatory Simulations Project web site.

Computer HubNet

Setting up a Computer Activity

Opening a Computer HubNet model will cause NetLogo to start a server which will allow people to join the activity. A dialog will prompt you to enter a unique name that will help participants identify the activity you are running. This name will appear if the server is discovered on the clients. While this is not necessary, entering a name is recommended since it can help reduce confusion over which activity participants should enter. You should then follow the instructions for the particular model found in the QuickStart Instructions monitor. Most models will require you to press a forever button, often called GO. You, as the leader, should notify everyone that they may join.

For them to join, you should give them the IP address for the computer that is running NetLogo. The IP address of the server can be found in the HubNet Control Center, which can be opened by choosing the HubNet Control Center option in NetLogo's Tools menu. Every user will have to enter this IP address to be able to enter the activity. On some systems, the HubNet Client will automatically detect all the Computer HubNet activities currently being run. On these systems, instead of typing in the IP address, everyone can select the activity from a list. Each item in the list should contain the unique name you entered in the dialog when you first opened the HubNet model followed by the name of the activity followed by the IP address of the computer running NetLogo.

Every participant will also have to enter a unique user name. (If a participant types in a user name that someone else is already using, they will be asked to choose a different name.)

Joining a Computer Activity

Once the leader has informed you that you can join, you should open up the HubNet Client application. This will prompt you for the IP address of the computer running NetLogo. Enter the IP address that the leader gave you. Alternately, if your network supports the "server discovery" feature, you may instead choose the activity from the list shown.

Regardless of how you choose the Computer HubNet server, you will also have to enter a User Name. Please enter one. The leader will give directions on how to choose one. If no one else is using the one you enter, NetLogo will send you the client interface and you can start playing. If you didn't choose a unique User Name, your client application will display a message indicating this. You should keep trying new User Names until you are able to enter. A good method for choosing a unique User Name is to use your first and last name together. For example, if your name is Joe Smith, you might want to choose the User Name, joesmith.

HubNet Control Center

One feature of Computer HubNet is the HubNet Control Center. You can open this using the HubNet Control Center option in the Tools Menu when a Computer HubNet Activity is open and the server is running. The Control Center shows you useful information, such as the IP address of the computer, who is logged in, etc. It also allows you to disconnect clients from the activity and send out instructions or messages for all the clients to read.

In addition to these features, the HubNet Control Center allows you to control whether debugging output is on or off. Debugging output is useful when creating your own HubNet activity or to keep track of which participant sent what data when. Any output is sent to the log.txt file on Windows machines, or the Console to Macs. The Control Center also allows you to control whether the NetLogo Graphics Window and plots are mirrored on the clients. These options are useful if there are a lot of changes to the Graphics Window or plots or if you just don't wish the clients to see what is happening on the clients. By default, these options are turned off since they are not suited for all models.

HubNet Authoring Guide

If you wish to learn more about authoring or modifying HubNet activities, you should look at the HubNet Authoring Guide.

Computer HubNet Troubleshooting Tips

Here are some things that have been known to go wrong and ways of fixing or working around them.

I have tried quitting a HubNet Client, but it just sits there and won't quit no matter how many times I try.

You will have to force the client to quit. On Macs, force quit the application (Command+Option+Esc). On Windows, open the Windows Task Manager (Ctrl+Alt+Delete), select Hubnet and press 'End Task'. Then you should inform the leader of the simulation to use the HubNet Control Center to kick your client out of the simulation.

We believe that we have resolved all instances of these problems with the exception of the client trying to quit when it has lost its network connection. If you encounter this problem and still have a network connection, please let us know.

When I open a Computer HubNet Activity, I got a dialog that said:

Could not start the Computer HubNet server. Another program may be using the port that is needed.

Another program (perhaps another copy of NetLogo) is using a port or some other resource that HubNet needs. Check to see if you have another copy of NetLogo open that is running Computer HubNet. If you do, quit it and then try reopening the model. If you don't, you can try quitting other programs and reopening the model until you are able to start the Computer HubNet server successfully.

Somehow two or more HubNet Clients are controlling the same agents in the simulation and they aren't supposed to. What can I do to fix this problem?

Remove all of the clients from the simulation by either by having the people exit the activity or by using the Kick Client feature in the HubNet Control Center to forcibly remove them. If you wish them to still be in the simulation, they all should log back in with different user names.

I had run and then stopped a HubNet model. I changed windows or minimized NetLogo or did something else to obscure or redraw the Graphics Window. When I came back to the NetLogo, the Graphics Window was all gray. What happened? Is all my data lost?

Most likely what has happened is that the Graphics Window is not longer being updated because the no-display primitive was called, or the freeze/unfreeze display button in the Graphics Window Control Strip is pressed. Try using the display primitive in the NetLogo Command Center or toggling the freeze/unfreeze display button.

My computer went to sleep while running a HubNet activity. When I woke the computer up, I got an error and HubNet wouldn't work anymore.

We have had reports that if a computer goes to sleep while running Computer HubNet (either the HubNet Client or the server), sometimes things do not work after the computer wakes up. Please send us the error message along with the situation that caused it. However, we suggest that people keep their computers from sleeping while running an activity.

In my HubNet client, I see the same server displayed multiple times in the list of available servers. Which one should I pick?

These all refer to the same server. Pick any of them to select that server.

The clients' Graphics Windows are not mirroring the NetLogo Graphics Window properly. What is the problem?

There are a few things that could be wrong.

If you verified that none of the above conditions apply, and mirroring is still not working for you, please contact us. We may be able to help you solve the problem, or it might be a bug.

If your situation does not fall into one of the above problem descriptions, please send us a bug report.

Known Computer HubNet Issues

If HubNet malfunctions, please send us a bug report. See the "Contact Us" section for instructions.

Known bugs (all systems)